Not the answer you need?
Register and ask your own question!
Many Forum changes were implemented on Tue 22 Sep. Read about new Ranks, Scoring, and Reactions.
Email [email protected] for any comments or concerns.

pm2 client tries 443 instead of 80

I configured my pmm-server to run on 80 port , but when i try to connect with pmm-admin config --server-url , even if i put the url:80 he tries the 443 port. It is mandatory 443 at client level ?

Comments

  • lalit.choudharylalit.choudhary Percona Percona Staff Role
    Hi Catalin,

    It is not mandatory to run pmm on 443, could you please provide docker command you are using for pmm-server install and pmm-admin config command with the output you are getting. Here I would like to know how you are checking/ concluding that pmm trying to connect to 443 port.

    In my test, I found that even after configured pmm-server to run on port 80 and also configuring pmm client as well to use port 80, it configured to use 443 port what we can see from /usr/local/percona/pmm2/config/pmm-agent.yaml and pmm-admin status output. Let us know if this case for you as well.

    Ref : https://jira.percona.com/browse/PMM-5072
  • StaterosStateros Contributor Current User Role Patron
    Hi Catalin, from security perspective it's very good to use 443 port for pmm. But if you don't have certificate and other staff, you can just add --server-insecure-tls flag in pmm-admin config command. It will skip checking ssl/tls, and you can use http link to your pmm-server.
    For example:
    pmm-admin config 10.10.10.10 generic best_db_name --server-insecure-tls --server-url=http://admin_user:admin_password@pmm.host.com/ --force
    
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.