Not the answer you need?
Register and ask your own question!

Import data into the Percona XtraDB Cluster with the mydumper tool

keithkeith ContributorCurrent User Role Novice
Hello everyone:

My PXC has 3 nodes , when I manually insert data and make changes, the cluster can replicate normally. But I import Percona Server data into the Percona XtraDB Cluster WRITE node with the mydumper tool, the others doesn't replication,only the one node I had import has data.

Import command :
myloader -u root -p -S mysql.sock -s database -d /tmp/backupdir/20190311 -o -t 16

I tried changing PXC Strict Mode to PERMISSIVE still doesn't work.

Thank you for any advice and help.


  • keithkeith Contributor Current User Role Novice
    Hi , I know why I am wrong. I forgot to add myloader to open binlog record parameters --enable-binlog . Everything is ok .Thank you .
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.