Not the answer you need?
Register and ask your own question!

pmm-admin configure

JoeHJoeH EntrantCurrent User Role Beginner
I have recently deployed PMM using an Amazon AWI. But am having difficulties running pmm-admin configure.
I run
$ pmm-admin config --username= --password= --server=1.2.3.4 replacing the username password and server with the appropriate values. The terminal window just hangs at the > prompt. I'm pretty sure that I'm using the correct username/password as if I enter anything elseI get an error. I've been trying to get this working for some time and this is my last shot before abandoning and using an alternate monitoring solution. Any help gratefully accepted.

Comments

  • lorraine.pocklingtonlorraine.pocklington Percona Community Manager Legacy User Role Patron
    Hello JoeH

    Apologies this slipped through the net. If you are able to give it another go, I have been able to get some advice from the team for you.

    We think you need to use the option "--server-user USERNAME" and "--server-pasword PASSWORD" arguments instead of --username/--password. Please check that you are using the right option names.

    By default, port 80 is used with PMM server like "1.2.3.4:80" and if you have configured different port, then mention the port explicitly. Also port 443 is used "--server 1.2.3.4:443" when SSL is enabled. You can also mention your pmm client's local (private) address with option "--bind-address 1.2.3.4" and pmm client's remote (public) address with "--client-address 1.2.3.4" option.

    So, if you are in a position to try again, see how you get on. I will watch out for your reply if you still need advice to get PMM going. Thanks for trying!
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.