Not the answer you need?
Register and ask your own question!

Innobackupex appears to do nothing

lekaf974lekaf974 EntrantCurrent User Role Beginner
Hi,

I want to restore an incremental backup but innobackupex appears to do nothing

my backup folder structure is

data/
|-- 2015-09-14-01-30-01/
| |-- backup-2015-09-14-01-30-01.xbstream.gz
| `-- xtrabackup_checkpoints
|-- 2015-09-15-01-30-01/
| |-- backup-2015-09-15-01-30-01.xbstream.gz
| `-- xtrabackup_checkpoints
|-- 2015-09-16-01-30-01/
| |-- backup-2015-09-16-01-30-01.xbstream.gz
| `-- xtrabackup_checkpoints
`-- 2015-09-17-01-30-01/
|-- backup-2015-09-17-01-30-01.xbstream.gz
`-- xtrabackup_checkpoints

I have a script to prepare the backup

it does :
steps :
1 / zcat data/2015-09-14-01-30-01/backup-2015-09-14-01-30-01.xbstream.gz | $xbstream -x -C prepared_backup
2 / innobackupex --apply-log --redo-only --use-memory=10G prepared_backup

etc..

At step2 it seems that nothing happens !

Example of what I have
XXXX:XXXXXX # ps aux | grep innobackupex
root     13539  0.0  0.0  79360 20212 pts/2    S+   11:29   0:00 perl /usr/local/xtrabackup/bin/innobackupex --apply-log --use-memory=10G prepared_backup
root     14365  0.0  0.0   5708   820 pts/1    S+   13:55   0:00 grep innobackupex
XXXX:XXXXXX # strace -p 13539 -s 1024
Process 13539 attached - interrupt to quit
futex(0x1549650, FUTEX_WAIT_PRIVATE, 2, NULL

The database to restore is about 210G
xtraback version is 2.2 (from sources)
OS Suse Enterprise 11 SP3

Someone have any idea to help me,

Thanks!

Comments

Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.