Not the answer you need?
Register and ask your own question!

Installing Percona Xtrabackup with WHM/CPanel

63bus63bus EntrantLegacy User Role Beginner
I asked this on the CPanel site:
http://forums.cpanel.net/f354/instal...el-431201.html
but no one was able to help so here goes:



[code]

Comments

  • 63bus63bus Entrant Legacy User Role Beginner
    Does anyone have any tips?

    I get the same thing when installing from source:
  • 63bus63bus Entrant Legacy User Role Beginner
    Tried this again today since I saw version 2.2.11 is out. Same issue. Can anyone help?
  • scott.nemesscott.nemes MySQL Sage Current User Role Patron
    Hi 63bus;

    Have you tried install the dependency explicitly through yum?

    yum install perl-DBD-MySQL

    Would be interested to see what it says about that. Dependency issues can be tricky to say the least.

    -Scott
  • 63bus63bus Entrant Legacy User Role Beginner
    The command above reports:
    No package perl-DBD-MySQL available.

    From above:
    DBD::mysql is up to date according to


    upgrade DBD::mysql

    I did run it again to be sure.
    It gave me:
    All modules are up to date for DBD::mysql
  • scott.nemesscott.nemes MySQL Sage Current User Role Patron
    Hi 63bus;

    Yeah, saw that it says it is installed via cpan, but thinking if you can get it through yum then that will get around the discrepancy issue.

    Looks like it must not be available in any of the repos you have hooked up. So you could:

    1) Configure another repo (should be in the standard "base" repo for Centos/RedHat)

    2) Try searching for it in Yum to see if it finds it by another name and then install it if you find it:
    yum search perl-dbd

    3) Download an RPM copy of it to install:
    http://rpmfind.net/linux/rpm2html/search.php?query=perl-DBD-mysql

    -Scott
  • 63bus63bus Entrant Legacy User Role Beginner
    Thank you.

    #2 nothing came up.

    #3 - My server is on CentOS5.11 for x86_64 - Looking at that listing it only gives me v3.0007.
    Is there any issue with installing the RPM for v3.0007 when I already have the latest 4.031 installed through CPAN?
  • scott.nemesscott.nemes MySQL Sage Current User Role Patron
    Hi 63bus;

    Installing the older version is not ideal, but assuming it lets you install it, then it should be fine. I'd just check anything else that uses it to make sure no issues pop up in case they start using the older version, but based on what you are seeing, I'm guessing they will remain separate and still use the newer version installed through CPAN. I've never used CPAN myself, so I'm just guessing based on the behavior you are describing so far.

    -Scott
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.