Not the answer you need?
Register and ask your own question!
Many Forum changes were implemented on Tue 22 Sep. Read about new Ranks, Scoring, and Reactions.
Email [email protected] for any comments or concerns.

Constant unrecognised queries

gbradleygbradley EntrantCurrent User Role Beginner
Hi,
I'm getting serveral unrecognised queries per second.

SELECT * FROM INFORMATION_SCHEMA.ROUTINES WHERE ROUTINE_SCHEMA='<DATABASE>' AND ROUTINE_NAME='<STORED PROCEDURE>'

I get these for different stored procedures and databases. I am using the .NET connector so I suppose it may be related to that. Any idea what these are?

There are others too:

Our web server is sending "SHOW VARIBLES".

Sometimes we get "SHOW COLLATION" (or something similar).

Does anyone know what these are? Especially the INFORMATION_SCHEMA.ROUTINES one?

Thanks,
Gareth

Comments

  • gbradleygbradley Entrant Current User Role Beginner
    A bit of further information:

    These queries are appearing in the slow_log as Full Table scans. Since they always refer to Stored Procedures called via the .NET connector, is it possible there is a bug in that?

    Any help would be greatly appreciated.

    Kind Regards,
    Gaz
  • sterinsterin Mentor Inactive User Role Contributor
    Do you have some sort of IDE or development environment connected against this server?

    Because I can't tell you why you are getting these queries.

    But I can tell you what they are.
    The INFORMATION_SCHEMA.ROUTINES table is used to get information about and the definition of the stored procedures that you have created in your DB.

    The SHOW VARIABLES are also used to get information about the current configuration of your DBMS.

    And the only reason I can thing of why you get these is because you are running some sort of development tool against this DB.

    As for the fact that you get a table scan for the query against INFORMATION_SCHEMA.ROUTINES it is nothing to worry about since that is actually not a table it is just a way to get meta information out from the DBMS.
  • gbradleygbradley Entrant Current User Role Beginner
    I believe I have found the problem. I was using the .NET connector (version 5.1.2.2). I have upgraded our systems to 5.1.4.0 and the number of queries have almost stopped. There maybe a rarely used system I've forgotten about that is still using the old connector.

    A quick look through the CHANGELOG suggests that Bug 29098 MAY be the problem, but I haven't dug into it to confirm.

    I will post back if I have further problems with this.

    The reason it has been bothering me is that MONyog has been reporting 50% Full table scans, which is primarily these.

    Thanks for your suggestions,

    Gareth
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.