Not the answer you need?
Register and ask your own question!
Many Forum changes were implemented on Tue 22 Sep. Read about new Ranks, Scoring, and Reactions.
Email [email protected] for any comments or concerns.

salve slow log

baoxiaobaoxiao ContributorCurrent User Role Beginner
When enable slave slow log, I set the long_query_time = 0 but in the slow log file, I can't get the actually query statement, all I find are things like below:

SET timestamp=1382458852;
BEGIN;
# [email protected]: [SQL_SLAVE] @ [] Id: 26
# Schema: mundotrack Last_errno: 0 Killed: 0
# Query_time: 0.000009 Lock_time: 0.000000 Rows_sent: 0 Rows_examined: 0 Rows_affected: 0
# Bytes_sent: 0

Any configuration missing?

Thanks,

James

Comments

  • niljoshiniljoshi MySQL Sage Inactive User Role Beginner
    Hi,


    http://dev.mysql.com/doc/refman/5.5/en/slow-query-log.html

    Are you using it? if not then can you try with that option? thanks.
  • baoxiaobaoxiao Contributor Current User Role Beginner
    I already enabled it.

    Thanks,

    James
  • przemekprzemek Percona Support Engineer Percona Staff Role
    James, this will work only if you are using STATEMENT based replication. For ROW, there are no actual queries, hence nothing will get logged from the replication stream.
  • baoxiaobaoxiao Contributor Current User Role Beginner
    It supposed to work this way or is a bug because with row based replication we can still get the query from slave binary log file if enable log_slave_update
  • niljoshiniljoshi MySQL Sage Inactive User Role Beginner
    Hi,

    Can you provide which exact MySQL/PS version you are using on Master/Slave? Need to test it before come on any conclusion. I have also found one bug related to this but don't know if it's same.
    https://bugs.launchpad.net/percona-server/+bug/625022

    Thanks.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.