Not the answer you need?
Register and ask your own question!

Required module missing !!!

systemalisystemali AdvisorCurrent User Role Beginner
Hello all,

I am trying to install the "Percona Toolkit" on my Centos 5.8 server and after i try to execute the "rpm -ivh percona-toolkit-2.1.8-1.noarch.rpm" command, I get the following error :-

error: Failed dependencies:
perl(DBD::mysql) >= 1.0 is needed by percona-toolkit-2.1.8-1.noarch


I am running MySQL version :- Distrib 5.1.61

Can any body let me know what do i need to do next ?

Comments

  • miguelangelnietomiguelangelnieto Member Inactive User Role Beginner
    Install the package perl-DBD-MySQL to solve that dependency. In order to avoid future dependency problem I recommend you to configure the Percona repository and then use yum to install the package:

    http://www.percona.com/docs/wiki/repositories:yum
  • systemalisystemali Advisor Current User Role Beginner
    Hello miguelangelnieto,

    Thank you for the prompt response, I shall give this a try and shall get back with an update.

    Thank you
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.