Not the answer you need?
Register and ask your own question!

Problems with SST

Os-TOs-T EntrantInactive User Role Beginner
Hi,

I upgraded one node to the new version of XtraDB Cluster and because of this the node now tries to get a SST from a donor.
Everything seems working smoothly (the donor doesn't report any errors and I can see the pipe with the xtrabackup-data with ps -Al).
But it seems, that xtrabackup on the node which receives the the SST doesn't can work the data.
innobackup.prepare.log says:

InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy and Percona Inc 2009-2012. All Rights Reserved.xtrabackup: Error: Please set parameter 'datadir'innobackupex: fatal error: no 'mysqld' group in MySQL optionsinnobackupex: fatal error: OR no 'datadir' option in group 'mysqld' in MySQL options</pre>


In /etc/mysql/my.cnf I have:

[mysqld]datadir=/var/lib/mysqltmpdir=/tmpuser=mysql</pre>

and of course many other options, but nothing overwrites these...

I have no idea how to set the datadir-option for innobackupex.

Thanks in advance!

Comments

  • ayurchenayurchen Contributor Inactive User Role Beginner
    You should have something like that in your node error log:

    120529 23:23:46 [Note] WSREP: Running: 'wsrep_sst_xtrabackup 'joiner' '192.168.0.3:3303' 'root:rootpass' '/tmp/galera2/mysql/var/' '/etc/my.cnf' '4693' 2>sst.err'</pre>

    Check that my.cnf path (5th argument) points to the right file.
  • Os-TOs-T Entrant Inactive User Role Beginner
    Thanks so much!!!
    The default config in the debian-package uses the /etc/mysql/conf.d/percona.cnf not the /etc/mysql/my.cnf
    After adding the datadir-param in this file everything works smoothly!
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.