Not the answer you need?
Register and ask your own question!

innobackupex :- corrupting tables

systemalisystemali AdvisorCurrent User Role Beginner
Hello all,

In my continued endeavor of setting up replication using "Xtrabackup" i have learnt that my replication on slave does not start , REASON being tables getting corrupted, that were being backed up using this command :-

innobackupex --user=yourDBuser --password=MaGiCdB1 /path/to/backupdir</pre>
"

Mentioned On this page :-


http://www.percona.com/doc/percona-xtrabackup/howtos/setting_up_replication.html</pre&gt;


I learnt about it after i ran the "mysqlcheck" on my slave server.

Can any one tell me, HOW CAN I AVOID such a data corruption during backup creation ?

Please assist ?

Thank you

Comments

  • davidchildersdavidchilders Contributor Current User Role Beginner
    Which version of MySQL is your master? Which version of MySQL is your slave?

    If they are a different version you will need to run the mysql_upgrade utility after the import into the slave.

    The slave can always be a newer version than the master, but not the other way around.

    That's about all I can imagine without further details.

    Are you capturing the output from the backup into any kind of log file?
  • systemalisystemali Advisor Current User Role Beginner
    Highly appreciate your turn around David,

    I have managed to reslove this issue, by upgrading the slave server with "percona mysql server" which i did not have earlier, I was infact using plain mysql that comes with the linux distro ...

    Since you have replied to my issue above, Can you let me know if it is mandatory to have Percona on both, master and slave servers for replication to happen ?

    Thank you for your time.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.