Not the answer you need?
Register and ask your own question!

XtraBackup Dependency Issue with Mysql 5.5.29

BrokenCrustBrokenCrust EntrantInactive User Role Beginner
I have a working installon of MySQL 5.5.28 on rhel 5 with XtraBackup 2.0.4

If I try to upgrade to MySQL 5.5.29 there is an error


rpm -Uhv MySQL-server-5.5.29-2.rhel5.x86_64.rpmerror: Failed dependencies: mysql is needed by (installed) percona-xtrabackup-2.0.4-484.rhel5.x86_64</pre>


NB: this method works fine for the last several upgrades.

If I uninstall Xtrabackup the upgrade works fine and MySQL 5.5.29 is installed and working but then it is not possible to install XtraBackup - the same error message is given.

NB: It is the same with XtraBackup 2.0.3 as well.

Comments

  • BrokenCrustBrokenCrust Entrant Inactive User Role Beginner
    Tried with 2.0.5 and have the same issue


    rpm -Uhv MySQL-server-5.5.29-2.rhel5.x86_64.rpmerror: Failed dependencies: mysql is needed by (installed) percona-xtrabackup-2.0.5-499.rhel5.x86_64</pre>
  • BrokenCrustBrokenCrust Entrant Inactive User Role Beginner
    This is still an issue with the MySQL 5.5.30 release.

    Does anyone know a workaround or have an idea if this will be fixed soon? I'm keen to upgrade MySQL to get recent security fixes; I can't move to Percona Server.
  • Dennis BDennis B Entrant Legacy User Role Beginner
    This is really a joke and renders percona xtrabackup useless.
    Doesn't work with MySQL 5.5.30 and neither xtraback 2.0.5 nor 1.6.5...
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.