Not the answer you need?
Register and ask your own question!

backup size

mugenbb6mugenbb6 EntrantInactive User Role Beginner
When I run "innobackupex --slave-info --safe-slave-backup --user=user --password=password /backupdir/", the backup is ~140gb which is about the size of my dataset. When I prep the backup with "innobackupex --apply-log /backupdir/timestamp", the backup grows to 250gb.

I thought this was due to new data being written to the slave, so I even tried to stop the slave replication to make sure no new data is submitted before running innobackupex, and the size still grows.

Here's my version:
innobackupex -version
InnoDB Backup Utility v1.5.1-xtrabackup;

My mysql version is 5.5.27

As a test, I've restored the backup to a test server, and my dataset is now 250gb. Running mysqlcheck optimize brings it back down to 140gb.

Comments

  • mugenbb6mugenbb6 Entrant Inactive User Role Beginner
    Not sure if it helps, but I'm running percona-xtrabackup-2.0.0.
  • mugenbb6mugenbb6 Entrant Inactive User Role Beginner
    I've installed the latest xtrabackup 2.0.3, and it's the same result. Any help will be appreciated.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.