Not the answer you need?
Register and ask your own question!

innobackupex gives error on mysql child process has died & password problem

rei125rei125 EntrantCurrent User Role Beginner
Hi,

(1) First question on error
I tried to did an innobackupex but it is giving me this error.

innobackupex: Error: mysql child process has died: sh: mysql: no such command</pre>


Previously i installed through rpm and it works fine (on the other server though).
Now i tried the binary package, percona-xtrabackup-2.0.1-446.tar.gz, but backup isnt working anynmore...

(2) 2nd question on password

Could someone please help me with it?

innobackupex --no-timestamp --user=root --password=xxx --defaults-file=/etc/sample/my.cnf /tmp/backup</pre>


This command works (ends with error in (1) though) but executing this on prompt will end up logging the password into system log file.
So i tried

innobackupex --no-timestamp --user=root --password=xxx --defaults-file=/etc/sample/my.cnf /tmp/backup</pre>

assuming that it will ask me to enter my password, just like the way we tried with mysql -uUSER -p
but it doesnt..
How to prompt innobackupex to ask for password from standard input?

Thank you.

Comments

  • rprabhurprabhu Entrant Current User Role Beginner
    For "innobackupex: Error: mysql child process has died: sh: mysql: no such command" first check if PATH variable is set correctly for innobackupex.

    Also, provide complete command-line and output of the command, it may also be that mysql may have gone away before it executed.
  • niljoshiniljoshi MySQL Sage Inactive User Role Beginner
    For 2nd question on password, I guess, you have two options.

    1. You can set user and password information in my.cnf like
    [client]
    user=<user>
    password=<pass>

    2. If you want to use it in command line but doesn't want to include in system log file, start the command with a space so it will not be recorded.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.