Not the answer you need?
Register and ask your own question!

Restore with innobackupex --apply-log fails

tmartenssontmartensson EntrantInactive User Role Beginner
Hi,
we are reinstalling our DB servers with CentOS 6.2 and I am having problems to restore a backup made with xtrabackup on CentOS 6.2.

The backup is made using innobackupexec and is streamed to our backupserver (that part is left out from the example below):

innobackupex-1.5.1 --safe-slave-backup --defaults-file=/etc/my.cnf --user=backupuser --password=passwd --slave-info --stream=tar /tmp </pre>


After this, I scp:d the backupfile to a new server with the same install base and exctracted it, now I want to run --apply-log but that throws out the error:

[[email protected] ~]# innobackupex --use-memory=2G --apply-log .InnoDB Backup Utili[..][...]sh: line 1: --print-param: command not foundinnobackupex: fatal error: no 'mysqld' group in MySQL optionsinnobackupex: fatal error: OR no 'datadir' option in group 'mysqld' in MySQL options</pre>


If I try:

[[email protected] ~]# innobackupex --defaults-file=/etc/my.cnf --use-memory=2G --apply-log .</pre>

I get the following error:

sh: line 1: --defaults-file=/etc/my.cnf: No such file or directoryinnobackupex: fatal error: no 'mysqld' group in MySQL optionsinnobackupex: fatal error: OR no 'datadir' option in group 'mysqld' in MySQL options</pre>


Details:
CentOS 6.2
xtrabackup-1.6.5-328.rhel6.x86_64
Percona-Server-client-51-5.1.60-rel13.1.413.rhel.x86_64
Percona-Server-server-51-5.1.60-rel13.1.413.rhel.x86_64
Percona-Server-shared-compat-5.5.21-rel25.1.234.rhel6.x86_64

Comments

  • tmartenssontmartensson Entrant Inactive User Role Beginner
    Running the xtrabackup command manually
    xtrabackup --defaults-file=/etc/my.cnf --use-memory=2G --prepare --target-dir=/data/backup/</pre>
    works, so I guess the perlscript (innobackupex) is broken.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.