Not the answer you need?
Register and ask your own question!

XtraDB Cluster one node boot error: Segmentation fault

seagenseagen ContributorInactive User Role Advisor
Now I am testing XtraDB Cluster following the URL: http://www.percona.com/doc/percona-xtradb-cluster/singlebox. html

The first one node is working well.
When I tried to start the second node,I met the above error mentioned: Segmentation fault. And I also logged the error information. Please see more as follow:
++++++
120213 18:03:11 [Note] WSREP: wsrep_load(): loading provider library '/usr/local/xtradbcluster/lib/libgalera_smm.so'
120213 18:03:11 [Note] WSREP: wsrep_load(): Galera 2.0beta(rXXXX) by Codership Oy <[EMAIL="info&#64;codership.com"][email protected][/EMAIL]> loaded succesfully.
120213 18:03:11 [Note] WSREP: Reusing existing '/data/db/xtradbcluster2//galera.cache'.
120213 18:03:11 [Note] WSREP: Passing config to GCS: gcache.dir = /data/db/xtradbcluster2/; gcache.keep_pages_size = 0; gcache.mem_size = 0; gcache.name = /data/db/xtradbcluster2//galera.cache; gcache.page_size = 128M; gcache.size = 128M; gcs.fc_debug = 0; gcs.fc_factor = 0.5; gcs.fc_limit = 16; gcs.fc_master_slave = NO; gcs.max_packet_size = 64500; gcs.max_throttle = 0.25; gcs.recv_q_hard_limit = 9223372036854775807; gcs.recv_q_soft_limit = 0.25; gmcast.listen_addr = [URL]tcp://0.0.0.0:5010[/URL]; replicator.commit_order = 3
120213 18:03:11 [Note] WSREP: wsrep_sst_grab()
120213 18:03:11 [Note] WSREP: Start replication



120213 18:03:11 [Note] WSREP: Assign initial position for certification: -1, protocol version: -1
120213 18:03:11 [Note] WSREP: Setting initial position to 00000000-0000-0000-0000-000000000000:-1
120213 18:03:11 [Note] WSREP: protonet asio version 0
120213 18:03:11 [Note] WSREP: backend: asio
120213 18:03:11 [Note] WSREP: GMCast version 0
120213 18:03:11 [Note] WSREP: (f00b117c-5629-11e1-0800-e389f3198479, '[URL]tcp://0.0.0.0:5010[/URL]') listening at [URL]tcp://0.0.0.0:5010[/URL]
120213 18:03:11 [Note] WSREP: (f00b117c-5629-11e1-0800-e389f3198479, '[URL]tcp://0.0.0.0:5010[/URL]') multicast: , ttl: 1
120213 18:03:11 [Note] WSREP: EVS version 0
120213 18:03:11 [Note] WSREP: PC version 0
120213 18:03:11 [Note] WSREP: gcomm: connecting to group 'trimethylxanthine', peer '192.168.109.6:4010'

You could find that there is one warning prompting as above,which is highlighted by myself. I don't why this file was not created by itself and why there is the additional slash behind the path /data/db/xtradbcluster2/.
Finally back to my puzzle: what could result in "Segmentation fault"?

Thanks and Regards,
Zhang

Comments

  • xaprbxaprb Mentor Inactive User Role Leader
    This might be two different problems. Please file a bug report on Launchpad and paste the URL here so other interested users can find it.
  • seagenseagen Contributor Inactive User Role Advisor
    Thank you,Baron.
    I already reported a bug on the Launchpad. But I am not sure whether the issue I mentioned here is a real bug and before I got stuck on my process and configuration with more suspicion.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.