Not the answer you need?
Register and ask your own question!

Dashboard show N/A

Hi all,

Success install PPM 2 using docker,

all running well, but my dashboard show N/A

how to make it show stats.

thank you.

Best Answer

Answers

  • steve.hoffmansteve.hoffman Percona Percona Staff Role

    guessing you're blocked by a firewall...check https://<pmm-server>/prometheus/targets and you'll probably see an error along the lines of "context deadline exceed" or similar. this typically means that a firewall is blocking the server from connecting to the exporters on ports 42000-4200x on each of your nodes.

    The other possibility is that hostnames used to register resolve to unreachable IP's...that would show as something like "no route to host".

    Check there and report back and we'll be able to better guide you (and if this is the case we have an awesome fix coming in the next release to make this a thing of the past!)

  • hafizhasssanhafizhasssan Current User Role Supporter

    hii @steve.hoffman

    thanks for your response.

    as i check, here are the output.

    just now i already open port 42001 in firewall-cmd.

    yet still down.

    thank you.

  • hafizhasssanhafizhasssan Current User Role Supporter

    here is my output for pmm-admin list

    @steve.hoffman


  • hafizhasssanhafizhasssan Current User Role Supporter
    edited November 21

    here output for pmm-admin status

    pmm server already have both 80 and 443

  • steve.hoffmansteve.hoffman Percona Percona Staff Role

    pmm2 MUST communicate over a secure channel so if you try port 80 and the communication is not secure it will default to try 443. If it can’t communicate on 443 over ssl it will fail to register. Registration communication is from client to server while exporter scraping is from server to client (direction of communication matters to most firewalls).

    seeing the error confirms my suspicions that there is a firewall somewhere blocking communication. From the pmm server, telnet to the client in port 42001 (‘telnet <client ip> 42001’).

    just to be doubly sure it’s not that the exporter failed to start you can telnet to the client up from the client.


    hope this helps!

  • hafizhasssanhafizhasssan Current User Role Supporter
    edited November 22

    already test the telnet. all node connected using 42001 port.

    pmm server already config with 443 port .

  • hafizhasssanhafizhasssan Current User Role Supporter

    here are the error.

    @steve.hoffman

  • steve.hoffmansteve.hoffman Percona Percona Staff Role

    Yes, the auth prompt is correct (We use a custom exporter that has authentication as an option compared to the community exporters which do not need/have auth). So from that standpoint you are seeing the correct behavior...which actually is a GOOD thing (is that from the system running pmm-server?)

    There's technically another layer between you and success...docker networking! since you can connect from server to client via telnet lets see if it works from inside the docker container:

    # docker exec -it <pmm-server> bash

    #telnet <pmm-server> 42001

    (you may have to install telnet inside the container image with 'yum install telnet')

    I have seen selinux and iptables rules give similar behavior. If you are able to connect via telnet from inside the pmm-server container then I'm completely stumped...but if you're not (and I really am hoping that's where the hiccup is!) feel free to post your iptables rules from your pmm-server (iptables --list -n) and we can potentially craft a rule to allow the traffic.

Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.