Not the answer you need?
Register and ask your own question!

Cannot show data on MongoDB replset dashboard after deploy monitor cassandra cluster

khuentkhuent EntrantCurrent User Role Supporter

Dear supporters,

I updated latest version 1.17.4, it worked perfectly until I installed and monitored cassandra node. I installed PMM-client and deploy cassandra follow this link: https://www.colabug.com/2019/0517/6225992/. I deployed successfully and show information on cassandra dashboard. But a few days ago, I had issue with mongoDB replicate, I tried to access MongoDB replset dashboard, It did not show any replicate data of MongoDB, only show cassandra cluster name "Adp_cluster", this is a screenshot

I tried to check pmm client status, i found all my database nodes (mysql and mongoDB) install external-service cassandra like this:


---------------- ------------------ ----------- -------- ---------------- --------------------

SERVICE TYPE   NAME        LOCAL PORT RUNNING DATA SOURCE   OPTIONS

---------------- ------------------ ----------- -------- ---------------- --------------------

mongodb:queries my-mongodb -      YES   127.0.0.1:27017 query_examples=true

linux:metrics  my-mongodb 42000    YES   -

mongodb:metrics my-mongodb 42003    YES   127.0.0.1:27017


Job name  Scrape interval Scrape timeout Metrics path Scheme Target        Labels           Health

cassandra 1m0s       10s       /metrics   http  1xx.xxx.xxx.xxx:8080 instance="hadoop-xxx" UP


Would you please help me fix this issue ?


Thank you!

Tagged:

Answers

  • adivinhoadivinho Percona Percona Staff Role

    Hi,

    It looks like your MongoDB services were added without a cluster name.

    We have fixed it for PMM2 https://jira.percona.com/browse/PMM-4562

    But dashboard variables are changed in PMM2 so you can't just take a dashboard from PMM2 and import it into PMM1.


    I will prepare a staging with PMM1 and provide you with required changes.

  • adivinhoadivinho Percona Percona Staff Role

    Variable "$cluster" should be changed by set ".*" for parameter "Custom all value".


  • khuentkhuent Entrant Current User Role Supporter

    Dear Adivinho,

    Thank you for your support. It worked perfectly !


    Best Regards,

Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.