Not the answer you need?
Register and ask your own question!

Set pitr.enabled to true gives error

jaschaiojaschaio Current User Role Novice

Hey there,

I am trying to enable Point In Time Recovery, as described in the documentation:

pbm config --set pitr.enabled=true

But I get the Following error:

Error: set config key: unexpected type invalid

If I execute pbm config --list I get my config as expected:

pitr:
  enabled: false
storage:
  type: s3
  s3:
    provider: aws
    region: eu-west-1
    bucket: mongodb-backups
    credentials:
      access-key-id: '***'
      secret-access-key: '***'

I can confirm that I am running the latest version via pbm version

Version:   1.3.1
Platform:  linux/amd64
GitCommit: b5f389676c6d3f11a027ee4aa782c6d4514bd854
GitBranch: release-1.3.1
BuildTime: 2020-09-02_04:56_UTC
GoVersion: go1.14.2

I guess I could maybe set it via the admin.pbmConfig database directly – but not sure if thats recommended

Answers

  • AndrewPogrebnoiAndrewPogrebnoi Percona Staff Role

    Hi @jaschaio ,


    Could you please update pbm to 1.3.2 version and try again?


    Cheers!

  • AndrewPogrebnoiAndrewPogrebnoi Percona Staff Role

    btw, we've checked one more time - v1.3.1 works fine as well.

    Your error looks like pbm unable to serialize that parameter from the db document. If 1.3.2 won't work for you, try delete document directly form admin.pbmConfig and reapply it via `pbm config --file=...`

  • jaschaiojaschaio Current User Role Novice

    Updating to 1.3.2 and then executing config --set pitr.enabled=true worked, thanks!

Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.