Not the answer you need?
Register and ask your own question!

Install specific mysql version fails

yotlesyotles EntrantCurrent User Role Novice
Hello.
What the correct way to install not the latest version of mysql from percona repo ps-80?
For example:
apt-cache policy percona-server-rocksdb
percona-server-rocksdb:
  Installed: (none)
  Candidate: 8.0.19-10-1.buster
  Version table:
     8.0.19-10-1.buster 500
        500 http://repo.percona.com/ps-80/apt buster/main amd64 Packages
     8.0.18-9-1.buster 500
        500 http://repo.percona.com/ps-80/apt buster/main amd64 Packages
     8.0.17-8-1.buster 500
        500 http://repo.percona.com/ps-80/apt buster/main amd64 Packages
     8.0.16-7-1.buster 500
        500 http://repo.percona.com/ps-80/apt buster/main amd64 Packages
     8.0.15-6-1.buster 500
        500 http://repo.percona.com/ps-80/apt buster/main amd64 Packages
apt-get install percona-server-rocksdb=8.0.18-9-1
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Version '8.0.18-9-1' for 'percona-server-rocksdb' was not found

apt-get install percona-server-rocksdb=8.0.18-9-1.buster
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 percona-server-rocksdb : Depends: percona-server-server (= 8.0.18-9-1.buster) but 8.0.19-10-1.buster is to be installed
E: Unable to correct problems, you have held broken packages.

Even if I try to install percona-server-server with needed version it still fails:
 apt-get install percona-server-server=8.0.18-9-1.buster
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 percona-server-server : PreDepends: percona-server-common (= 8.0.18-9-1.buster) but 8.0.19-10-1.buster is to be installed
                         Depends: percona-server-client (= 8.0.18-9-1.buster) but 8.0.19-10-1.buster is to be installed
E: Unable to correct problems, you have held broken packages.

So I need to pin one by one all dependencies or what the correct way to install 8.0.18-9-1 version, for example?

Answers

  • Evgeniy PatlanEvgeniy Patlan Percona Percona Staff Role
    hi @yotles
    If you want to install some specific version of Percona Server for Mysql you need to specify all packages and versions for them, Below you can find the example how to install Percona Server for MySQL 8.0.18 and rocksdb package for it:
    apt-get install percona-server-rocksdb=8.0.18-9-1.buster percona-server-server=8.0.18-9-1.buster percona-server-common=8.0.18-9-1.buster percona-server-client=8.0.18-9-1.buster


Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.