Cannot add remote MySQL instance due to Connection check failed

gdsotirovgdsotirov Active Member Poster
On a fresh PMM 2.6.1 installation I'm not able to add a remote MySQL instance, because of connection check failures. I've followed the procedure for running PMM server via Docker and I have set up a user on the MySQL server instance as described in Creating a MySQL User Account to Be Used with PMM. My Docker host is a fully updated CentOS 8.1 virtual machine and my MySQL server instance is on a physical machine in the same network segment. I have access from the virtual machine to the MySQL sever with the pmm's user and password. From within the container I have ping to the MySQL server instance. However, when adding new remote MySQL instance I'm getting either of the following errors:
  • Connection check failed: dial tcp 192.168.0.1:3306: i/o timeout.
  • Connection check failed: dial tcp 192.168.0.1:3306: connect: no route to host.
What could be the problem?



Comments

  • daniil.bazhenovdaniil.bazhenov Percona Admin
    edited May 25
    Hi, @gdsotirov
    Thank you for your question. This could be a bug. Could you create a task in Jira (https://jira.percona.com/projects/PMM/issues), our developers will investigate it.
    Thank you.
  • gdsotirovgdsotirov Active Member Poster
    @daniil.bazhenov It could be something with the configuration of the container or the host, because I meanwhile noticed that if I run the container with --network=host there are no errors when adding the same MySQL instance. I'm still doubtful it's a bug, because I use the official container and followed the official procedure, which are expected to work.


  • daniil.bazhenovdaniil.bazhenov Percona Admin
    @gdsotirov
    Yeah, you might have a bad password or some kind of network error. 
    P.S. I recommended Jira, because engineers can investigate the problem there. 
  • gdsotirovgdsotirov Active Member Poster
    @daniil.bazhenov To me it seems that PMM is not even getting to password verification. Otherwise, I ensured that the user/password work from the same host where the container runs. And also as I wrote before it works just fine if I run the container with --network=host option, but this is not my preference except for testing. If found no such problem reported in JIRA or elsewhere on Internet, so I still wonder what could be the problem in my case. What else I could try and/or check before reporting a bug?

    P.S. I have pulled the container image from Docker Hub and executed the procedure at least twice to be sure I haven't mixed up something the first time.



  • daniil.bazhenovdaniil.bazhenov Percona Admin
    @gdsotirov The fastest way to create a task at Jira, then the team will check it out. It's free :) 
  • gdsotirovgdsotirov Active Member Poster
    Fair enough. Issue PMM-6041 created.




Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.