Not the answer you need?
Register and ask your own question!

Unable to start Postgresql exporters using extend.query-path

Revana SidduRevana Siddu Current User Role Contributor

Hi,

I have installed PMM1.17.3 and PMM client 1.17.3 , Node exprter working fine . Postgresql_exprters also working fine.

when i removed and added postgresql exporter with extend query pmm-admin check-network showing down..

[[email protected] prometheus]# pmm-admin add postgresql:metrics –user pmm_user –password secret postgres –host slxxxldbd192 –port 5432 –service-port 9187 –disable-ssl –extend.query-path /pgworkspace/software/prometheus/queries.yaml
* Connection: Client <– Server
——————- ————— ——————— ——- ———- ———
SERVICE TYPE NAME REMOTE ENDPOINT STATUS HTTPS/TLS PASSWORD
——————- ————— ——————— ——- ———- ———
linux:metrics slxxxldbd192 10.1xx0.1xx.221:9100 OK NO –
postgresql:metrics postgres 10.1xx.109.221:9187 DOWN NO –
PMM Server | slxxxeldbd217 (insecure SSL)
Client Name | sxxxseldbd192.visa.com
Client Address | 10.1xx0.1xx9.xx21
Service Manager | linux-systemd
——————- ————— ———– ——– ——————————————– ————
SERVICE TYPE NAME LOCAL PORT RUNNING DATA SOURCE OPTIONS
——————- ————— ———– ——– ——————————————– ————
linux:metrics sl7xxldbd192 9100 YES – scheme=http
postgresql:metrics postgres 9187 YES postgresql:***@sl73gxxxd192:5432/postgres scheme=http
pmm_user=# show is_superuser
pmm_user-# ;
is_superuser
————–
on
(1 row)


time=”2020-03-31T09:35:20Z” level=info msg=”Starting postgres_exporter (version=, branch=, revision=)” source=”postgres_exporter.go:1132″
time=”2020-03-31T09:35:20Z” level=info msg=”Build context (go=go1.10.1, user=, date=)” source=”postgres_exporter.go:1133″
time=”2020-03-31T09:35:20Z” level=info msg=”Established new database connection.” source=”postgres_exporter.go:1015″
time=”2020-03-31T09:35:20Z” level=info msg=”Semantic Version Changed: 0.0.0 -> 11.2.0″ source=”postgres_exporter.go:945″
time=”2020-03-31T09:35:20Z” level=info msg=”Starting HTTP server for http://1x.1xx.1xx.2×1:9187/metrics …” source=”server.go:121″

Answers

  • adivinhoadivinho Percona Percona Staff Role
    I can't reproduce the issue. Could you make sure that the used port is accessible from the server side?
    # telnet 10.178.2.154 9187    
    Trying 10.178.2.154...
    Connected to 10.178.2.154.
    Escape character is '^]'.

    Here are commands that were used on the client side:
    # pmm-admin add postgresql:metrics --user ec2-user --password secret --service-port 9187 --disable-ssl -- --extend.query-path /home/ec2-user/queries.yaml  
    OK, now monitoring PostgreSQL metrics using DSN postgresql:***@/postgres

    # lsof -i:9187            
    COMMAND    PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
    postgres_ 7172 root    5u  IPv4  54439      0t0  TCP ip-10-178-2-154.us-east-2.compute.internal:9187 (LISTEN)
    postgres_ 7172 root    6u  IPv4  54441      0t0  TCP ip-10-178-2-154.us-east-2.compute.internal:9187->ip-172-17-0-2.us-east-2.compute.internal:38806 (ESTABLISHED)

Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.