Not the answer you need?
Register and ask your own question!

I cannot delete PerconaXtraDBCluster ressources in kubernetes

eleanereleaner EntrantCurrent User Role Novice
Hi,

I was trying to set up a cluster in my Kubernetes using helm charts.

I ended up with some strange resources I cannot delete



kubectl get PerconaXtraDBCluster -n zabbix NAME ENDPOINT STATUS PXC PROXYSQL AGE zabbix-db-pxc-db 10h zabbix-pxc-db 9h





when I try to delete them, the process basically hangs

I also tried to delete the namespace with the same result

I don't see any pods

kubectl get all -n zabbix No resources found in zabbix namespace.



possibly important information is that the controller is created in the default namespace and (hopefully) configured to look at zabbix namespace

version 1.3.0

kubectl get pod NAME READY STATUS RESTARTS AGE pxc-operator-5d5c8ffd9-29qpc 1/1 Running 0 13h
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.