PMM2 client not registering

I have been following the process of installing the PMM2 server and client from:
https://www.percona.com/blog/2019/09/19/installing-percona-monitoring-and-management-pmm-2-for-the-first-time/

and get to the very last point of registering the client on the server and it doesn't work. It responds with:
Checking local pmm-agent status...
pmm-agent is running.
Registering pmm-agent on PMM Server...
Failed to register pmm-agent on PMM Server: Post https://admin:3/v1/management/Node/Register: dial tcp: lookup admin on ***.***.***.***: no such host.

Two things are strange here - the IP address shown in the error is not the IP address of the server or the one listed in the --server-url (odd) and also when I put the incorrect password in, it fails due to:
Failed to register pmm-agent on PMM Server: Invalid username or password.

Any advice would be greatly appreciated..

Thank you

Comments

  • StaterosStateros Contributor Active Member Advisor
    Are you using httpS for your PMM Server?
  • howlerhowler Entrant Active Member Participant
  • milosbmilosb Contributor Active Member Participant
    Depending on what username/password are, you may have to URL encode them in order to register the client with the PMM server.

    As you probably know, special characters take different form in URLs - and you're using an URL to register. E.g. if the password you're using is: [email protected]$$w0rd, the URL encoded form
    would be P%40%24%24w0rd
  • howlerhowler Entrant Active Member Participant
    Genius! Thank you!!!
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.