Not the answer you need?
Register and ask your own question!

No query analytics after upgrade from 1.17.1 to 1.17.2

I upgraded my server and clients and now there is no analytics data. Says mysql not configured correctly. It was working before and I triple checked my mysql servers and verified that they are configured correctly as per the documentation link. I tried removing and installing the service several times. Are other people seeing this? Am I missing something?

Comments

  • daveadavea Entrant Current User Role Novice
    Okay, I have solved this one. I tailed the qan logs on the server and there is activity and no errors. I then looked at a 7 day history and there was no data to be found. Data coming in but not being displayed after an upgrade. I thought maybe there is a problem with the pmm-data container so I removed and rebuilt it, then reconnected the clients, for the 6th time, and it started working. So the typical upgrade process that is supposed to preserve data doesn't work here. You need to rebuild the pmm-data container for this upgrade loosing all your data.
  • daveadavea Entrant Current User Role Novice
    Oh, and it was that way on both staging and production servers. So not just a quirk.
  • daveadavea Entrant Current User Role Novice
    Apparently I was wrong. It has gone back to not showing queries again. Not sure what is going on here. Don't upgrade to 1.17.2 if you need query analytics.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.