Not the answer you need? Try our search, browse our categories, or register and ask your own question!

Jemalloc installed but not shown as being used after reboot (RHEL 7.6)

RolyRoly EntrantActive Member Participant
I installed Percona and want to use jemalloc as stated here
https://www.percona.com/blog/2017/01/03/enabling-and-disabling-jemalloc-on-percona-server/

I rebooted as stated in the instructions, but when the database returns I find its not applied jemalloc

Percona version


I check the status with:
pt-mysql-summary | grep -A5 -i "memory management"

# pt-mysql-summary | grep -A5 -i "memory management"
# Memory management library ##################################
jemalloc is not enabled in mysql config for process with id 12999
# The End ####################################################



# find / -name "libjemalloc*"
/usr/lib64/libjemalloc.so.1

So can I find some clues as to why its not being used by Percona ? I need this functionality as this database will be under quite some load.

Thanks!

Comments

  • RolyRoly Entrant Active Member Participant
    /etc/sysconfig/mysql should contain
    LD_PRELOAD=/usr/lib64/libjemalloc.so.1 # Memory management library ################################## jemalloc enabled in mysql config for process with id 17795 Using jemalloc from /usr/lib64/libjemalloc.so.1 # The End ####################################################
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.