Not the answer you need?
Register and ask your own question!

MySQL 5.5 on Debian 9 (stretch) can't find libssl1.0.0

j4nd3r53nj4nd3r53n ContributorCurrent User Role Poster
I am trying to install MySQL 5.5 (has to be that version, unfortunately) on a freshly installed Debian 9 system, and there is one dependency that I can't easily fix, it seems:
dpkg: dependency problems prevent configuration of percona-server-server-5.5:
 percona-server-server-5.5 depends on percona-server-client-5.5 (>= 5.5.44-rel37.3-1.jessie); however:
  Package percona-server-client-5.5 is not configured yet.
 percona-server-server-5.5 depends on libdbd-mysql-perl; however:
  Package libdbd-mysql-perl is not installed.
 percona-server-server-5.5 depends on libaio1 (>= 0.3.93); however:
  Package libaio1 is not installed.
 percona-server-server-5.5 depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0 is not installed.

However, this package is no longer available, apparently:
root@ip-10-0-1-64:~/mysql# dpkg-query -l 'libssl*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                                          Version                             Architecture                        Description
+++-=============================================================-===================================-===================================-================================================================================================================================
un  libssl1.0.0                                                   <none>                              <none>                              (no description available)
ii  libssl1.0.2:amd64                                             1.0.2s-1~deb9u1                     amd64                               Secure Sockets Layer toolkit - shared libraries
ii  libssl1.1:amd64                                               1.1.0k-1~deb9u1                     amd64                               Secure Sockets Layer toolkit - shared libraries

Is there a way to fix this?

Comments

  • j4nd3r53nj4nd3r53n Contributor Current User Role Poster
    The solution to this problem turns out to be to add something extra to the apt source list - this isn't mentioned in the official documentation, as far as I can see:
    # install percona for mysql 5.5
    /usr/bin/wget https://repo.percona.com/apt/percona-release_latest.stretch_all.deb
    /usr/bin/dpkg -i *deb
    cat > /etc/apt/sources.list.d/percona.list <<!
    deb http://repo.percona.com/apt stretch main
    deb-src http://repo.percona.com/apt stretch main
    !
    /usr/bin/apt-get update
    DEBIAN_FRONTEND=noninteractive /usr/bin/apt-get -q -y install percona-server-server-5.5
    /usr/bin/percona-release enable-only tools release
    /usr/bin/apt-get update
    DEBIAN_FRONTEND=noninteractive /usr/bin/apt-get -q -y install percona-xtrabackup-24
    
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.