Not the answer you need?
Register and ask your own question!
An upgrade to Forum ranks and points will occur about noon New York time today, Tue 22 Sep. The Forum may be briefly in read-only mode. [email protected]

PMM2 - no query analytics for MySQL

NickmobNickmob ContributorCurrent User Role Patron
Hi!

Successfully added 2 hosts to PMM2 instance. Linux and Mysql metrics are working fine, but Query Analytics section is empty.
How to debug this problem?

Here's my command to add service

pmm-admin add mysql --query-source=slowlog --username=root --password=1 sl-mysql 127.0.0.1:3306

pmm-admin list

Service type Service name Address and port Service ID
MySQL 127.0.0.1:3306 127.0.0.1:3306 /service_id/f977c1e8-8bd5-4d34-ac21-aeb84d525824

Agent type Status Agent ID Service ID
pmm-agent connected /agent_id/bb997998-0f44-4721-ae67-c281b7017ea1
node_exporter running /agent_id/0a2f203c-062c-4faf-a285-c42968f34398
mysqld_exporter running /agent_id/8d5e4227-f2d9-4ab8-a000-e8a963ecf19c /service_id/f977c1e8-8bd5-4d34-ac21-aeb84d525824
qan-mysql-slowlog-agent running /agent_id/5f485939-b8fd-40f8-8ad3-e43e4ae4d737 /service_id/f977c1e8-8bd5-4d34-ac21-aeb84d525824

pmm-admin status
Agent ID: /agent_id/bb997998-0f44-4721-ae67-c281b7017ea1
Node ID : /node_id/81d30999-cdd2-4daf-af10-6a5a9cc37d08

PMM Server:
URL : https://admin:***********@**********:443/
Version: 2.0.1

PMM-agent:
Connected : true
Time drift: 1.217224ms
Latency : 355.723µs

Agents:
/agent_id/0a2f203c-062c-4faf-a285-c42968f34398 NODE_EXPORTER RUNNING
/agent_id/5f485939-b8fd-40f8-8ad3-e43e4ae4d737 QAN_MYSQL_SLOWLOG_AGENT RUNNING
/agent_id/8d5e4227-f2d9-4ab8-a000-e8a963ecf19c MYSQLD_EXPORTER RUNNING

Comments

  • catalin08catalin08 Entrant Current User Role Beginner
    I have the same issues :(. If i remove the service and add it again for one minute data is imported.
  • StaterosStateros Contributor Current User Role Patron
    Just to be sure, have you enable slow_query log in your DB config?
  • linuxfarmerlinuxfarmer Entrant Current User Role Novice
    Is it possible that you just don't have any queries reaching the value for long_query_time set on your MySQL instance?
  • NickmobNickmob Contributor Current User Role Patron
    Is it possible that you just don't have any queries reaching the value for long_query_time set on your MySQL instance?

    Nope, long_query_time = 0. Just no queries at all. Also, I have only 1 mysql instance working in monitoring out of 3 servers.
  • NickmobNickmob Contributor Current User Role Patron
    Finally figured it out!
    The problem is clickhouse. It's prebuilt for CPUs with support of SSE 4.2 (see https://github.com/ClickHouse/ClickHouse/issues/1170), so it cannot be used with older CPUs.
    Symptoms are: clickhouse cannot start in docker: Illegal instruction (core dumped)
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.