Not the answer you need?
Register and ask your own question!

PMM clients cannot use both ssl and password?

I have set up a pmm server and enabled both ssl and added a username and password. When trying to connect with pmm-admin I can not get it to connect using ssl and a username and password. I get this error:
This client is configured with HTTP basic authentication.
However, PMM server is not.
If you forgot to enable password protection on the server, you may want to do so.
Otherwise, run the following command to reset the config and disable authentication:
pmm-admin config --server pmm.example.com --server-ssl

I can get it to connect if I remove the username and password.
I can connect to the web interface using the username and password. So I know that the server has accepted the server user and password settings.

I follow these instructions
Combining Security Features
and use the insecure connection and get the same error. Is there something I am supposed to be doing on the server side to enable pmm clients to use password auth?

This doesn't work:
pmm-admin config --server-user myuser --server-password mypassword --server staging-pmm.example.com --server-ssl --client-address xxx.xxx.xxx.xxx

pmm-admin config --server-user myuser --server-password mypassword --server staging-pmm.example.com --server-insecure-ssl --client-address xxx.xxx.xxx.xxx

This works:
pmm-admin config --server staging-pmm.example.com --server-ssl --client-address xxx.xxx.xxx.xxx

server systemd startup section:
ExecStart=/usr/bin/docker run \
--name pmm-server \
--volumes-from pmm-data \
--restart always \
-e SERVER_USER=myuser \
-e SERVER_PASSWORD=mypassword \
-v /etc/ssl_certs:/srv/nginx \
-v /etc/grafana/pmm:/etc/grafana \
-p=443:443 \
percona/pmm-server

I have searched the docs with no luck so far. Any help with understanding this would be appreciated.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.