Not the answer you need?
Register and ask your own question!

cluster not start after reboot

rpereyrarpereyra EntrantCurrent User Role Novice
Hi all !

I followed the cluster installation tutorial with 3 nodes and everything seems to work perfectly.

However, I restarted the first node and from that moment the cluster does not start on one node.

service mysql restart-bootstrap
[ ok ] Stopping mysql (via systemctl): mysql.service.
[FAIL] Bootstrapping Percona XtraDB Cluster database server: mysqld .[....] The server quit without updating PID file (/var/run/mysqld/mysqld.pid). ... failed!
failed!
[email protected]:/etc/mysql# service mysql restart-bootstrap
[ ok ] Stopping mysql (via systemctl): mysql.service.
[FAIL] Bootstrapping Percona XtraDB Cluster database server: mysqld .[....] The server quit without updating PID file (/var/run/mysqld/mysqld.pid). ... failed!
failed!


cat my.cnf
#
# The Percona XtraDB Cluster 5.7 configuration file.
#
#
# * IMPORTANT: Additional settings that can override those from this file!
# The files must end with '.cnf', otherwise they'll be ignored.
# Please make any edits and changes to the appropriate sectional files
# included below.
#
!includedir /etc/mysql/conf.d/
!includedir /etc/mysql/percona-xtradb-cluster.conf.d/

### cluster
[mysqld]
wsrep_provider=/usr/lib/libgalera_smm.so
wsrep_cluster_name=munigchu-cluster
wsrep_cluster_address=gcomm://90.0.0.1,90.0.0.2,90.0.0.3
wsrep_node_name=db1-mysql-cluster
wsrep_node_address=90.0.0.1
wsrep_sst_method=xtrabackup-v2
wsrep_sst_auth=sstuser:passw0rd
pxc_strict_mode=ENFORCING
##pxc_strict_mode=DISABLED
binlog_format=ROW
default_storage_engine=InnoDB
innodb_autoinc_lock_mode=2

How I can debug this issue ?

thanks in advance for any help.

roberto

Comments

  • rpereyrarpereyra Entrant Current User Role Novice
    this issue was solved rebooting server again, thanks

    roberto
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.