Not the answer you need?
Register and ask your own question!

Ubuntu apt dist-upgrade wants to remove Percona from our server

ofriasofrias ContributorInactive User Role Novice
Hello.

It looks like something is broken in the repos because apt dist-upgrade wants to delete our Percona cluster server packages:

# apt update
Hit:1 http://de.archive.ubuntu.com/ubuntu bionic InRelease
Get:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]
Hit:3 http://de.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://de.archive.ubuntu.com/ubuntu bionic-backports InRelease
Hit:5 http://repo.percona.com/apt bionic InRelease
Fetched 83.2 kB in 0s (247 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
5 packages can be upgraded. Run 'apt list --upgradable' to see them.

# apt list --upgradable
Listing... Done
percona-release/unknown,unknown 1.0-3.generic all [upgradable from: 0.1-6.bionic]
percona-xtradb-cluster-57/unknown 5.7.24-31.33-1.bionic amd64 [upgradable from: 5.7.23-31.31-2.xenial]
percona-xtradb-cluster-client-5.7/unknown 5.7.24-31.33-1.bionic amd64 [upgradable from: 5.7.23-31.31-2.xenial]
percona-xtradb-cluster-common-5.7/unknown 5.7.24-31.33-1.bionic amd64 [upgradable from: 5.7.23-31.31-2.xenial]
percona-xtradb-cluster-server-5.7/unknown 5.7.24-31.33-1.bionic amd64 [upgradable from: 5.7.23-31.31-2.xenial]

# apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
iproute libcurl3 libev4 libmecab2 libnuma1 librtmp1 lsof percona-xtrabackup-24 qpress socat
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
percona-xtradb-cluster-57 percona-xtradb-cluster-server-5.7
The following packages will be upgraded:
percona-release percona-xtradb-cluster-client-5.7 percona-xtradb-cluster-common-5.7
3 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
Need to get 2,416 kB of archives.
After this operation, 97.7 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.


Could you please review this?

Thanks!

Comments

  • hrvojemhrvojem Percona Percona Staff Role
    Hi,

    Can you please provide more information on what's been done before this? It looks like you've upgraded from xenial to bionic and that you're trying to upgrade pxc now as well?

    Thanks,
    Hrvoje
  • ofriasofrias Contributor Inactive User Role Novice
    Hi.

    Thanks for your reply. The server was initially installed with Ubuntu 16.04 Xenial and Percona Cluster, and updated to Bionic a few months ago. I have been running apt update and dist-upgrade more or less weekly without any problem. And today I have found this issue.

    Thanks!
  • hrvojemhrvojem Percona Percona Staff Role
    Hi,

    On xenial packages require libcurl3 and on bionic libcurl4 package, and it looks like apt can't do automatic upgrade.

    I've logged https://jira.percona.com/browse/PXC-2341 for this issue. Current workaround is to remove the xenial pxc packages and install bionic (instead of running dist-upgrade).
  • ofriasofrias Contributor Inactive User Role Novice
    I really don't feel safe removing Percona package from one our production servers, I am afraid I can lose some configuration or data. I prefer to wait until the deb is fixed to do the standard dist-upgrade.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.