Not the answer you need?
Register and ask your own question!

*Error 9002: SSL connection is required. Please specify SSL options and retry.

I have installed percona pmm monitoring using Docker:
$ docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
345ed86acdad docksal/ssh-agent:1.2 "docker-entrypoint.s…" 28 hours ago Up 16 hours (healthy) docksal-ssh-agent
4f8906245a0c percona/pmm-server:latest "/opt/entrypoint.sh" 2 weeks ago Up 16 hours 0.0.0.0:80->80/tcp, 443/tcp pmm-server

and trying to setup/access remote mysql instance on Azure, but getting error:

*Error 9002: SSL connection is required. Please specify SSL options and retry.
Not sure where do i setup ssl option in pmm
Thanks,
-Kamal.

Comments

  • Michael CoburnMichael Coburn Principal Architect, Percona Percona Staff Role
    Hi kamal2222ahmed

    Apologies for the tardiness of the reply, I don't have a solution for you but allow me to reach out to an Engineer who can provide a perspective. Thank you for your patience!
  • RhuntonRhunton Entrant Current User Role Novice
    Hi - Was this ever resolved? I'm attempting to do the same, but can't find SSL options for "pmm-admin add" and there are no SSL parameters available when adding a remote database in the PMM GUI.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.