Not the answer you need?
Register and ask your own question!

Auto increment gap in master master setup

jazikhjazikh ContributorCurrent User Role Novice
Hello,
I was using mariadb 5.5 before but now I have upgraded it and
using percona xtradb cluster 5.6
I have 3 nodes cluster. I am only using single node for read and write.

I saw some increment gaps in ids so i had to turn off wsrep auto increment control.

I am still confused about innodb_autoinc_lock_mode which is 2 and bin log format is Row.

Is it safe to make it 1 to avoid gaps issue since we are only using single node for write and read?

Thanks

Comments

Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.