Not the answer you need?
Register and ask your own question!

Failing to deploy new cluster

bar1bar1 EntrantCurrent User Role Beginner
Hi everyone, been struggling with this for a few days now.

I have 1 MariaDB database, i am using cluster control to deploy a 3 node cluster.
I am running a mariaDB backup , when i restore i get this message:


[18:28:19]: Failed to restore backup.
[18:28:19]: ??v: failed to run mysql_upgrade, but the backup was restored. Please check server logs.
[18:28:19]: xxx: '/usr/bin/mysql_upgrade --skip-write-binlog --force -u'root' -p'******'' failed, check the log in Logs -> Database Logs for this server. Run it manually on this server. Error: '/usr/bin/mysql_upgrade…
[18:28:17]: xxx: running mysql_upgrade.
[18:28:17]: xxx: Restarted mysql daemon.

I see the 1 node is synced but the other 2 are not.

REP_SST: [INFO] Waiting for SST streaming to complete! (20181001 16:38:29.499)
2018-10-01 16:38:30 0 [Note] WSREP: (6c0e0ff9, 'tcp://0.0.0.0:4567') connection to peer 6c0e0ff9 with addr tcp://xxx:4567 timed out, no messages seen in PT3S
2018-10-01 16:38:30 0 [Note] WSREP: (6c0e0ff9, 'tcp://0.0.0.0:4567') turning message relay requesting off
2018-10-01 16:38:39 0 [Warning] WSREP: 0.0 (xxx): State transfer to 1.0 (xxx2) failed: -22 (Invalid argument)
2018-10-01 16:38:39 0 [ERROR] WSREP: gcs/src/gcs_group.cpp:gcs_group_handle_join_msg():737: Will never receive state. Need to abort.
2018-10-01 16:38:39 0 [Note] WSREP: gcomm: terminating thread
2018-10-01 16:38:39 0 [Note] WSREP: gcomm: joining thread
2018-10-01 16:38:39 0 [Note] WSREP: gcomm: closing backend
WSREP_SST: [ERROR] xtrabackup_checkpoints missing, failed innobackupex/SST on donor (20181001 16:38:39.648)
WSREP_SST: [ERROR] Cleanup after exit with status:2 (20181001 16:38:39.672)
2018-10-01 16:38:39 0 [ERROR] WSREP: Process completed with error: wsrep_sst_mariabackup --role 'joiner' --address 'xxxx' --datadir '/var/lib/mysql/' --parent '7763' '' : 2 (No such file or directory)
2018-10-01 16:38:39 0 [ERROR] WSREP: Failed to read uuid:seqno and wsrep_gtid_domain_id from joiner script.
2018-10-01 16:38:39 0 [ERROR] WSREP: SST failed: 2 (No such file or directory)
2018-10-01 16:38:39 0 [ERROR] Aborting

can anyone assist?

Comments

  • phoenixphoenix Contributor Inactive User Role Contributor
    This might be a silly question but why are you asking about a MariaDB problem on the Percona site rather than on the MariaDB forums?
  • DBennettDBennett Percona Director of DS Inactive User Role
    bar1,

    You may want to check the sstuser permissions on your nodes. See the Configuring Percona XtraDB Cluster on ... pages in our documentation.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.