Not the answer you need?
Register and ask your own question!

Unable to communicate with Consul: Unexpected response code: 400 (Missing node name)

Hi.

I'm having problems to use pmm-admin config.

Whenever I execute command
pmm-admin config --server 172.16.37.6:8088

I get as response the following:

Unable to communicate with Consul: Unexpected response code: 400 (Missing node name)

and configuration file is not created. Then I added to command as shown below

pmm-admin config --verbose --server 172.16.37.6:8088

and I got the following:
2018/07/16 18:01:56 request:
> GET /qan-api/ping HTTP/1.1
> Host: 172.16.37.6:8088
> User-Agent: Go-http-client/1.1
> Accept-Encoding: gzip
>
>
2018/07/16 18:01:56 response:
< HTTP/1.1 200 OK
< Access-Control-Allow-Headers: Content-Type,Authorization
< Access-Control-Allow-Methods: GET,PUT,POST,DELETE
< Access-Control-Allow-Origin: *
< Cache-Control: no-store
< Connection: keep-alive
< Content-Type: text/plain; charset=utf-8
< Date: Mon, 16 Jul 2018 21:00:34 GMT
< Pragma: no-cache
< Server: nginx
< Strict-Transport-Security: max-age=63072000; includeSubDomains
< X-Content-Type-Options: nosniff
< X-Frame-Options: DENY
< X-Percona-Qan-Api-Version: 1.12.0-1806122339.901f5ea
< X-Xss-Protection: 1; mode=block
< Content-Length: 0
<
<
2018/07/16 18:01:56 request:
> GET /v1/status/leader HTTP/1.1
> Host: 172.16.37.6:8088
> User-Agent: Go-http-client/1.1
> Accept-Encoding: gzip
>
>
2018/07/16 18:01:56 response:
< HTTP/1.1 200 OK
< Content-Length: 16
< Connection: keep-alive
< Content-Type: application/json
< Date: Mon, 16 Jul 2018 21:00:34 GMT
< Server: nginx
< X-Remote-Ip: 172.16.4.29
< X-Server-Time: Monday, 16-Jul-2018 21:00:34 GMT
<
< "127.0.0.1:8300"
2018/07/16 18:01:56 request:
> GET /v1/catalog/node/ HTTP/1.1
> Host: 172.16.37.6:8088
> User-Agent: Go-http-client/1.1
> Accept-Encoding: gzip
>
>
2018/07/16 18:01:56 response:
< HTTP/1.1 400 Bad Request
< Content-Length: 17
< Connection: keep-alive
< Content-Type: text/plain; charset=utf-8
< Date: Mon, 16 Jul 2018 21:00:34 GMT
< Server: nginx
<
< Missing node name
Unable to communicate with Consul: Unexpected response code: 400 (Missing node name)


I've also tried command
pmm-admin config --server 172.16.37.6:8088  --bind-address 172.16.4.29 --client-address  172.16.4.29

but I got the same result.

As you can see I'm lost. Any ideas are very much appreciated.

Environment:

Server
IP: 172.16.37.6
Port: 8088
PMM Server running in a docker container


Client
IP: 172.16.4.29


Thanks in advance.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.