Not the answer you need?
Register and ask your own question!

want to refresh EC2 server MySQL DB with AWS RDS DB, facing issues

sivakrishnasivakrishna EntrantInactive User Role Beginner
please provide steps with my.cnf file I've tried by giving some configuration but it not worked, to refresh my preprod db with prod rds db instance. kindly provide some process for that

my.cnf file

[client]
user=xxx

password=ssxx

host=xxxxxx.xx.rds.amazonaws.com

port=3306

databases=db1

[mysqld]

socket=/var/lib/mysql/mysql.sock

symbolic-links=0

collation-server = utf8_unicode_ci

init-connect='SET NAMES utf8'

character-set-server = utf8


#server_id = 2

log_bin = mysql-bin

expire_logs_days = 6

binlog_format = ROW

max_binlog_size = 1024M

innodb_strict_mode = 0

log-error=/var/log/mysqld.log

pid-file=/var/run/mysqld/mysqld.pid

max_allowed_packet = 1024M

show_compatibility_56 = ON




innodb_data_home_dir = /rdsdbdata/db/innodb

innodb_data_file_path = ibdata1:12M:autoextend

innodb_log_group_home_dir = /rdsdbdata/log/innodb

innodb_log_files_in_group = 2

innodb_log_file_size = 0

innodb_buffer_pool_size = 12G

innodb_log_buffer_size = 256M

innodb_log_file_size = 1G

innodb_write_io_threads = 16

innodb_flush_log_at_trx_commit = 0

innodb_force_recovery = 1

#Below lines to enable crash safe replication for more info visit https://www.percona.com/blog/2013/09/13/enabling-crash-safe-slaves-with-mysql-5-6/

relay_log_info_repository = TABLE

master_info_repository = TABLE

relay_log_recovery = ON

skip-character-set-client-handshake

max_execution_time = 3000000

====EOF

Getting the below error:

xtrabackup: using the following InnoDB configuration:

xtrabackup: innodb_data_home_dir = /rdsdbdata/db/innodb

xtrabackup: innodb_data_file_path = ibdata1:12M:autoextend

xtrabackup: innodb_log_group_home_dir = /rdsdbdata/log/innodb

xtrabackup: innodb_log_files_in_group = 2

xtrabackup: innodb_log_file_size = 1073741824

InnoDB: Number of pools: 1

InnoDB: Error: log file /rdsdbdata/log/innodb/ib_logfile0 is of different size 0 bytes

InnoDB: than specified in the .cnf file 1073741824 bytes!
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.