Not the answer you need?
Register and ask your own question!

Option --tables-exclude does not behavior as expected

lujinkelujinke EntrantInactive User Role Beginner
Recently I found the --tables-exclude option does not behavior as expected.
The backup command i used:
innobackupex --defaults-file=/usr/local/mysql-5.7.12/my.cnf --user=root --host=localhost --socket=/var/lib/mysql/mysql1.sock --password=root --no-timestamp --tables-exclude=test.t backup

There are three tables in database test,e.g. t,t2 and t3, i want to exclude table t from the backup, but i found innobackupex excludes all of the three tables.
Does --tables-exclude always treat the option value as regex that if the table in database test contains char 't' and that table will be excluded?



innobackupex version:
innobackupex version 2.4.8 Linux (x86_64) (revision id: 97330f7)
MySQL version: 5.7.12

Feel free to response,thanks!

Comments

  • lujinkelujinke Entrant Inactive User Role Beginner
    Hi, i found i should use --databases-exclude option instead:
    --databases-exclude=test.t does fulfill my demand though it's a little weird.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.