Not the answer you need?
Register and ask your own question!

sst/ist not working properly

ramzeyphysiqramzeyphysiq EntrantCurrent User Role Beginner
i get the following error when trying to get my second node to join the the first boostrapped node. below is my config

2017-10-30T20:19:21.748969Z 0 [Note] WSREP: Initiating SST/IST transfer on JOINER side (wsrep_sst_xtrabackup-v2 --role 'joiner' --address '172.16.99.182' --datadir '/physiq/mysql/data/' --defaults-file '/etc/my.cnf' --defaults-group-suffix '' --parent '1891' '' )
which: no openssl in (/usr/sbin:/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin)
2017-10-30T20:19:22.356645Z 0 [ERROR] WSREP: Failed to read 'ready <addr>' from: wsrep_sst_xtrabackup-v2 --role 'joiner' --address '172.16.99.182' --datadir '/physiq/mysql/data/' --defaults-file '/etc/my.cnf' --defaults-group-suffix '' --parent '1891' ''
Read: ''openssl' not found in PATH'
2017-10-30T20:19:22.361146Z 0 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup-v2 --role 'joiner' --address '172.16.99.182' --datadir '/physiq/mysql/data/' --defaults-file '/etc/my.cnf' --defaults-group-suffix '' --parent '1891' '' : 2 (No such file or directory)
2017-10-30T20:19:22.361282Z 1 [ERROR] WSREP: Failed to prepare for 'xtrabackup-v2' SST. Unrecoverable.
2017-10-30T20:19:22.361323Z 1 [ERROR] Aborting


[mysqld]
datadir=/physiq/mysql/data
log-error=/var/log/mysqld.log
# replication and binlog related options
user=mysql
wsrep_provider=/usr/lib64/libgalera_smm.so
wsrep_cluster_name=pxc-cluster
wsrep_cluster_address=gcomm://172.16.99.181,172.16.99.182,172.16.99.183

wsrep_node_address=172.16.99.182
wsrep_node_name=lxc-rdbms-02

wsrep_sst_method=xtrabackup-v2
wsrep_sst_auth=sstuser:s3cret

log_error_verbosity=3
default_storage_engine=InnoDB
innodb_autoinc_lock_mode=2
pxc_encrypt_cluster_traffic=ON
ssl-ca=/physiq/mysql/ca.pem
ssl-cert=/physiq/mysql/server-cert.pem
ssl-key=/physiq/mysql/server-key.pem


Once I enable ssl and sst on my perconadb cluster i get the following message when my second node tries to join up with the bootstrapped node. I have no clue how to troubleshoot this as I dont see anything on the boostrapped node indicating a problem.

2017-10-30T19:56:57.291819Z 0 [Note] WSREP: Flow-control interval: [141, 141]
2017-10-30T19:56:57.291835Z 0 [Note] WSREP: Trying to continue unpaused monitor
2017-10-30T19:56:57.291847Z 0 [Note] WSREP: Shifting OPEN -> PRIMARY (TO: 0)
2017-10-30T19:56:57.291934Z 2 [Note] WSREP: State transfer required:
Group state: 0191138b-bdac-11e7-b22c-9f7765bc7e83:0
Local state: 00000000-0000-0000-0000-000000000000:-1
2017-10-30T19:56:57.291959Z 2 [Note] WSREP: New cluster view: global state: 0191138b-bdac-11e7-b22c-9f7765bc7e83:0, view# 2: Primary, number of nodes: 2, my index: 1, protocol version 3
2017-10-30T19:56:57.291973Z 2 [Note] WSREP: Setting wsrep_ready to true
2017-10-30T19:56:57.291985Z 2 [Warning] WSREP: Gap in state sequence. Need state transfer.
2017-10-30T19:56:57.291995Z 2 [Note] WSREP: Setting wsrep_ready to false
2017-10-30T19:56:57.292092Z 0 [Note] WSREP: Initiating SST/IST transfer on JOINER side (wsrep_sst_xtrabackup-v2 --role 'joiner' --address '172.16.99.182' --datadir '/physiq/mysql/data/' --defaults-file '/etc/my.cnf' --defaults-group-suffix '' --parent '780' '' )
which: no openssl in (/usr/sbin:/sbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin)
2017-10-30T19:56:57.973232Z 0 [ERROR] WSREP: Failed to read 'ready <addr>' from: wsrep_sst_xtrabackup-v2 --role 'joiner' --address '172.16.99.182' --datadir '/physiq/mysql/data/' --defaults-file '/etc/my.cnf' --defaults-group-suffix '' --parent '780' ''
Read: ''openssl' not found in PATH'
2017-10-30T19:56:57.977945Z 0 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup-v2 --role 'joiner' --address '172.16.99.182' --datadir '/physiq/mysql/data/' --defaults-file '/etc/my.cnf' --defaults-group-suffix '' --parent '780' '' : 2 (No such file or directory)
2017-10-30T19:56:57.978156Z 2 [ERROR] WSREP: Failed to prepare for 'xtrabackup-v2' SST. Unrecoverable.
2017-10-30T19:56:57.978189Z 2 [ERROR] Aborting

Comments

  • vadimtkvadimtk Contributor Percona Staff Role
    i get the following error when trying to get my second node to join the the first boostrapped node. below is my config

    Read: ''openssl' not found in PATH'

    As error indicates, install openssl packages for your OS
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.