Not the answer you need?
Register and ask your own question!

PMM Version 1.3.0 and mongodb

erinoerino ContributorInactive User Role Beginner
I've upgraded to pmm 1.3.0 (clients and servers). I was wondering how adding mongodb:queries has changed? Mongo is running. mongodb:metrics is running.
but it barfs on sudo pmm-admin add mongodb:queries. And after it barfed I had to run a pmm-admin repair.
the pmm-admin check-network shows that everything is ok

Comments

  • erinoerino Contributor Inactive User Role Beginner
    I upgraded pmm client to 1.3.1
    pmm-admin list

    pmm-admin 1.3.1
    pmm server is also 1.3.1
    mongodb is: db.version() 3.0.15

    We just upgraded from 2.6.9.

    I added the mongodb:queries (since I had 1.3.1 & mongo have been upgraded). But the
    pmm-admin add mongodb:queries fails
    and the https://pmm-server/qan-api/instances has this:
    "Subsystem":"mongo","ParentUUID":XXX, "Id":0,"UUID": XXX, Name:XXX, ,"DSN":"localhost:27017", "Distro":"MongoDB","Version":"2.6.9","Created":"2017-06-01T17:30:50Z","Deleted":"1970-01-01T00:00:01Z"} Since I just created it it tells me I have some old bit in my installation.
    I've done this:
    sudo pmm-admin rm mongodb:metrics and this: curl -X "DELETE" 'http://10.100.100.71/qan-api/instances/XXX' <-- disappears from the qan-api/instances when I run this: curl -s 'http://USER:[email protected]/v1/internal/ui/nodes?dc=dc1' | python -mjson.tool <-- mongodb:queries is not in there. how do I actually really remove my old add?
  • erinoerino Contributor Inactive User Role Beginner
    More info:
    I ran the env -i /usr/bin/pt-mongodb-summary
    completed with a 0 and shows the correct version of MongoDB.

    I figured it's in more than the consul so I jumped into the docker container & checked out the db. The old qan is in the mysqldb pmm.instances, pmm.agent_configs (probably the agent_log too). The rest of the tables look like InnoDB centric.

    in the qan-api.log, I see all the PUT, GET, DELETEs for that instance. I need to forget that instance of MongoDB as it is labeled version 2.6.9 & now is 3.0.15. I'm not so sure I should be deleting the qan data from the pmm mysql db.

    .
  • MykolaMykola Percona Percona Staff Role
    Am I understand correctly, you have only one issue -- new QAN interface show wrong version for MongoDB instance?
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.