Not the answer you need?
Register and ask your own question!

PMM request error/template init failed etc.

We setup PMM server as a VM and installed pmm-client on one of our MariaDB servers. Configured pmm-server and the client node but the PMM graphs does not populate anything. It neither shows the host that has pmm-client installed.
When opening Metrics Monitor page, it gives "Templating init failed" and "Request Error" for each graph panel. When opening QAN page, it gives "QAN API error". Attached screenshots of these errors.

The pmm client log has these messages:
2017/09/06 10:07:43.635269 WARNING data-sender Cannot connect to API:  bad status
2017/09/06 10:08:20.076584 WARNING log-ws bad status
2017/09/06 10:08:20.076690 WARNING agent-ws bad status
2017/09/06 10:08:50.631109 WARNING data-sender Cannot connect to API:  websocket.Dial ws://10.187.79.196:80/qan-api/agents/862188b1790d449a5b12ea563d6d4208/data: dial tcp 10.187.79.196:80: i/o timeout
2017/09/06 10:09:00.631718 WARNING data-sender Cannot connect to API:  websocket.Dial ws://10.187.79.196:80/qan-api/agents/862188b1790d449a5b12ea563d6d4208/data: dial tcp 10.187.79.196:80: getsockopt: connection refused
2017/09/06 10:09:03.632574 WARNING data-sender Cannot connect to API:  websocket.Dial ws://10.187.79.196:80/qan-api/agents/862188b1790d449a5b12ea563d6d4208/data: dial tcp 10.187.79.196:80: getsockopt: connection refused

When I try to connect to PMM server QAN API, I get this error:
[user@pmm-client]$ curl http://user:password@10.187.79.196:80/qan-api/
<html>
<head><title>502 Bad Gateway</title></head>
<body bgcolor="white">
<center><h1>502 Bad Gateway</h1></center>
<hr><center>nginx</center>
</body>
</html>

Any pointers to solve this? Thanks!

Comments

Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.