Not the answer you need?
Register and ask your own question!

Bridged only? Cannot use Host only networking?

rdab100rdab100 ContributorCurrent User Role Patron
All docs seem to say OVA has to use bridged networking and don't use NAT ... but simply cannot do that, have to use host only network as using openvswitch to control the networks. However at command line when run the grep cloud-init /tmp/pmm-server-console.log I get:

Starting Initial cloud-init job (pre-networking)...
[ 13.547195] cloud-init[733]: Cloud-init v. 0.7.5 running 'init-local' at Tue, 09 May 2017 09:44:46 +0000. Up 13.40 seconds.
localhost login: [ 45.375352] cloud-init[1044]: Cloud-init v. 0.7.5 running 'init' at Tue, 09 May 2017 09:45:18 +0000. Up 45.20 seconds.
[ 45.500484] cloud-init[1044]: ci-info: +++++++++++++++++++++++Net device info+++++++++++++++++++++++
[ 45.500774] cloud-init[1044]: ci-info: +
+
+
+
+
+
[ 45.500878] cloud-init[1044]: ci-info: | Device | Up | Address | Mask | Hw-Address |
[ 45.500977] cloud-init[1044]: ci-info: +
+
+
+
+
+
[ 45.501118] cloud-init[1044]: ci-info: | lo: | True | 127.0.0.1 | 255.0.0.0 | . |
[ 45.502071] cloud-init[1044]: ci-info: | eth0: | True | . | . | 08:00:27:ff:d0:4d |
[ 45.502185] cloud-init[1044]: ci-info: +
+
+
+
+
+
[ 45.502285] cloud-init[1044]: ci-info: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!Route info failed!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[ 46.352303] cloud-init[1044]: 2017-05-09 09:45:19,494 - util.py[WARNING]: Failed accessing user data.
[ 47.198576] cloud-init[1758]: Cloud-init v. 0.7.5 running 'modules:config' at Tue, 09 May 2017 09:45:20 +0000. Up 47.12 seconds.
[ 47.477027] cloud-init[1819]: Cloud-init v. 0.7.5 running 'modules:final' at Tue, 09 May 2017 09:45:20 +0000. Up 47.40 seconds.
[ 47.520166] cloud-init[1819]: 2017-05-09 09:45:20,663 - util.py[WARNING]: Failed running /var/lib/cloud/scripts/per-boot/show-pmm-url [1]
[ 47.520298] cloud-init[1819]: 2017-05-09 09:45:20,663 - cc_scripts_per_boot.py[WARNING]: Failed to run module scripts-per-boot (per-boot in /var/lib/cloud/scripts/per-boot)
[ 47.520426] cloud-init[1819]: 2017-05-09 09:45:20,663 - util.py[WARNING]: Running scripts-per-boot (<module 'cloudinit.config.cc_scripts_per_boot' from '/usr/lib/python2.7/site-packages/cloudinit/config/cc_scripts_per_boot.pyc'>) failed
[ 47.534614] cloud-init[1819]: Cloud-init v. 0.7.5 finished at Tue, 09 May 2017 09:45:20 +0000. Datasource DataSourceNone. Up 47.52 seconds
[ 47.534772] cloud-init[1819]: 2017-05-09 09:45:20,672 - cc_final_message.py[WARNING]: Used fallback datasource

Which would seem a bit obvious... no networking address applied to eth0 so the DHCP bit isn't working. Anyone else got OVA to run using host only networking? I can start up another vm and it picks up an IP address fine.

Or anyone done this with a vagrantfile? Build a Centos/Debian box and then install in the normal way (if there was an install available? I could not find one)?

PMM-Server is closed right I couldn't find any source?

Dom

Comments

Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.