Not the answer you need?
Register and ask your own question!

Percona 5.6.34 numa config question

jthorpe77jthorpe77 EntrantCurrent User Role Beginner
We just upgraded from percona 5.6.28 to 5.6.34. When I started mysql up as root, it printed these messages:
Starting MySQL (Percona XtraDB Cluster)./usr/bin/mysqld_safe: line 931: test: ON: integer expression expected
/usr/bin/mysqld_safe: line 956: test: ON: integer expression expected
... SUCCESS!

These messages were not printed in the error log.
Since it looked like it was complaining about my.cnf variables defined as 'ON', I tested this by changing
flush_caches = ON
to
flush_caches = 1

On the restart, these messages were not printed.

It is not clear what the definitions should be in my.cnf. The 5.5 documentation says use values 0/1, but then 5.6 docs clearly say use ON/OFF.
But clearly flush_caches=1 is wanted for 5.6.34.
I am inclined to set these in my.cnf:
flush_caches = 1
numa_interleave = 1
innodb_buffer_pool_populate = 1
I can confirm that numa_.. and innodb_.. are set correctly, but do not find flush_caches in show [global] variables?

Does anyone have advice here?

Comments

  • Kenn TakaraKenn Takara Percona Percona Staff Role
    Looking through the code, the flush_caches option is used by the mysqld_safe.sh script and not part of the server itself (which is why it doesn't show up in "show variables"). Also, the script only checks to see if the variable is equal to 1.

    I think the docs for 5.6 are incorrect, the correct values are 0 or 1.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.