Not the answer you need?
Register and ask your own question!

xtrabackup failure after upgrade mariadb from 10.0 to 10.1

Davide SpagnoliDavide Spagnoli EntrantInactive User Role Beginner
Hello everybody,
we currently use xtrabackup (innobackupex 2.3.5) in our production and testing environment with mariadb 10.0 (XtraDB/InnoDB). We create a clean copy of current database for our developing software purpose.
In test environment we have upgraded mariadb version to the last one (stable) 10.1. From that moment the backups created by innobackupex are corrupted: after a complete restore, made with import tablespace, we have a lot of column (typically Datetime and Int) with wrong value, it seems at the beginning of range of the type of that column.
In mariadb 10.1 we haven't enabled neither encryption nor compression. We also have tried last version of innobackupex (2.4.3) with the same result.
Is there an known incompatibility issue between mariadb 10.1 and innobackupex?
Thank you in advance for any kind of suggestion
Bye

Comments

Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.