Not the answer you need?
Register and ask your own question!

percona-nagios-plugins-1.1.6 on an OEL5 system compatibility

znamorznamor EntrantInactive User Role Participant
Hello,

When attempting to install "percona-nagios-plugins-1.1.6" on an OEL5 system the installation process fails:

$cat /etc/*release
Enterprise Linux Enterprise Linux Server release 5.8 (Carthage)
Oracle Linux Server release 5.8
Red Hat Enterprise Linux Server release 5.8 (Tikanga)
...
$yum install percona-nagios-plugins
Loaded plugins: priorities, security
nexus_rpm | 1.5 kB 00:00
nexus_rpm_snapshots | 1.5 kB 00:00
52 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package percona-nagios-plugins.noarch 0:1.1.6-1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================================================================================================
Package Arch Version Repository Size
============================================================================================================================================================================================================================================
Updating:
percona-nagios-plugins noarch 1.1.6-1 enservio 29 k

Transaction Summary
============================================================================================================================================================================================================================================
Install 0 Package(s)
Upgrade 1 Package(s)

Total size: 29 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by percona-nagios-plugins-1.1.6-1.noarch
rpmlib(PayloadIsXz) is needed by percona-nagios-plugins-1.1.6-1.noarch
Complete!
(1, [u'Please report this error in [url]https://bugzilla.redhat.com/enter_bug.cgi?product=Red Hat Enterprise Linux 5&component=yum'][/url])

The above error indicates as if the 1.1.6 plugins package is not designed for OEL5 but for OEL6 or later platforms?!?

Here is a post that indicates thats the case:
http://serverfault.com/questions/280099/how-do-i-install-an-rpm-that-complains-about-rpmlibfiledigests-4-6-0-1

'Percona Monitoring Plugins Documentation Release 1.1.6' PDF which I read does not have any specifics on minimum kernel version required and just specifies the MySql version required:

"1.2 System Requirements
The plugins are all written in standard Unix shell script. They should run on any Unix or Unix-like operating system, such as GNU/Linux, Solaris, or FreeBSD.
The plugins are designed to be used with MySQL 5.0 and newer versions, but they may work on 4.1 or older versions as well."

What version of the plugins is supposed to be compatible w/OEL5 - 1.1.4 or 1.1.5 or 1.1.6?

Many thanks in advance!
---Roman
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.