Not the answer you need?
Register and ask your own question!

change in command line?

johntestjohntest ContributorInactive User Role Beginner
I had been using this in cron for full and incremental backups

FULL
innobackupex --parallel=4 --rsync --socket /var/lib/mysql/mysql.sock /backup/sql
INCREMENTAL
innobackupex --incremental --parallel=4 --rsync --socket /var/lib/mysql/mysql.sock /backup/sql

The 2nd line for Incremental used to work previously with xtrabackup version 2.2
It would put both full and incremental backups with timestamp in the same directory which is what I want.

I have now upgraded to
percona-xtrabackup-2.3.4

And the incremental cron job above also creates FULL backups!

What am I doing wrong??

OS is CentOS 6.7

Thanks

Comments

  • johntestjohntest Contributor Inactive User Role Beginner
    ok I see the problem. With the new 2.3 version innobackupex is deprecated hence its having problems.

    I just tried
    xtrabackup --backup --socket /var/lib/mysql/mysql.sock --target-dir=/var/backup

    but this does not create a directory with timestamp.
    I have looked at xtrabackup options and unless I overlooked something I don't see an option to just specify a single directory and have everything put there with timestamps like innobackupex could do.

    How can I do this?


    Also the full backup worked fine but the following resulted in an error

    xtrabackup --backup --target-dir=/backup/mon --incremental-basedir=/backup/sun --socket /var/lib/mysql/mysql.sock

    Gives this ERROR
    Error: failed to execute query FLUSH NO_WRITE_TO_BINLOG CHANGED_PAGE_BITMAPS: Access denied; you need (at least one of) the SUPER privilege(s) for this operation
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.