Not the answer you need?
Register and ask your own question!

upgrade percona-server-server-5.6 to 5.7

xs1vexs1ve EntrantCurrent User Role Beginner
Hello!
My task is to update to 5.7 percona. on jessie 8.2

That's what I'm doing:
apt-get remove percona*
apt-get install percona-server-server-5.7


But it did not get to run percona 5.7, so that otput:
2016-03-26T17:57:40.972545Z 0 [Warning] Could not increase number of max_open_files to more than 65536 (request: 81925)
2016-03-26T17:57:40.972803Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2016-03-26T17:57:40.974366Z 0 [ERROR] --initialize specified but the data directory has files in it. Aborting.
2016-03-26T17:57:40.974396Z 0 [ERROR] Aborting

dpkg: error processing package percona-server-server-5.7 (--configure):
subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.19-18+deb8u2) ...
Processing triggers for systemd (215-17+deb8u3) ...
Errors were encountered while processing:
percona-server-server-5.7
E: Sub-process /usr/bin/dpkg returned an error code (1)


2016-03-26T17:59:44.496118Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2016-03-26T17:59:44.853137Z 0 [Warning] InnoDB: New log files created, LSN=45790
2016-03-26T17:59:44.918997Z 0 [Warning] InnoDB: Creating foreign key constraint system tables.
2016-03-26T17:59:44.986867Z 0 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: 85bc3d55-f37c-11e5-b0d8-901b0e8b1229.
2016-03-26T17:59:44.992031Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2016-03-26T17:59:45.154714Z 0 [Warning] CA certificate ca.pem is self signed.
2016-03-26T17:59:45.334111Z 1 [Warning] [email protected] is created with an empty password ! Please consider switching off the --initialize-insecure option.
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
2016-03-26T17:59:50.139410Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2016-03-26T17:59:50.289171Z 0 [Warning] CA certificate ca.pem is self signed.
dpkg: error processing package percona-server-server-5.7 (--configure):
subprocess installed post-installation script returned error exit status 1
E: Sub-process /usr/bin/dpkg returned an error code (1)
W: Operation was interrupted before it could finish

dpkg -l | grep percona
iF percona-server-server-5.7 5.7.11-4-1.jessie

When you upgrade to 5.5 to 5.6 did not have such problems.

Please tell me what could be the problem???
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.