Not the answer you need?
Register and ask your own question!

pt-table-sync fails "Turning off AutoCommit"

alvarado-viragalvarado-virag EntrantCurrent User Role Beginner
While trying to use pt-table-sync with the following options for a list of slaves:

pt-table-sync --print --replicate schema.checksum_table --sync-to-master slave-001

I receive the following error message on some of the slaves:
DBD::mysql::db STORE failed: Turning off AutoCommit failed at /usr/lib/perl5/DBI.pm line 723.

The MySQL version for the slave is 5.6.17 and for the master 5.6.15. Other slaves for which this does work also have MySQL 5.6.15 version.
I am able to turn off session autocommit if I log in to the slave directly using MySQL client and the same user being used for pt-table-sync.
The checksum table in use was created by previously running pt-table-checksum.

DBI.pm version:
$ perl -MDBI -e 'print "$DBI::VERSION\n";'
1.63

Has anyone encountered this issue before?

Please let me know if you need me to provide more information.

Thank you.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.