Not the answer you need?
Register and ask your own question!

Xtrabackup restore from Swift fail with: wrong chunk magic at offset 0x0.

vedwardsvedwards EntrantInactive User Role Beginner
Hello,
I am having an issue with trying to retrieve a backup from our swift cluster I receive the error: xb_stream_read_chunk(): wrong chunk magic at offset 0x0.

Here is the information for our setup:
Xtrabackup version -> xtrabackup version 2.3.2 based on MySQL server 5.6.24 Linux (x86_64) (revision id: 306a2e0)
MariaDB Galera Cluster Version -> Server version: 10.0.21-MariaDB-wsrep MariaDB Server, wsrep_25.10.r4144
Swift Version -> swift 2.4.0


Here is the command I run for backups (I get the completed ok message at the end of the backup - see nippit) :
innobackupex --user=$USER --password=$PASSWORD \
--socket=/var/lib/mysql/mysql.sock --stream=xbstream \
--extra-lsndir=/tmp/swift-lsn /tmp/swift-lsn \
| xbcloud put --storage=Swift --swift-container=$SWIFT_BACKUP_CONTAINER \
--swift-user=$SWIFT_BACKUP_USER \
--swift-auth-url=$SWIFT_BACKUP_AUTH_ADDRESS \
--swift-key=$SWIFT_BACKUP_KEY \
--parallel=4 full_backup


Here is my log saying my backup completed successfully:
151111 21:35:27 Executing UNLOCK TABLES
151111 21:35:27 All tables unlocked
151111 21:35:27 Backup created in directory '/tmp/swift-lsn/2015-11-11_21-35-21'
151111 21:35:27 [00] Streaming backup-my.cnf
151111 21:35:27 [00] ...done
151111 21:35:27 [00] Streaming xtrabackup_info
151111 21:35:27 [00] ...done
xtrabackup: Transaction log of lsn (1620087) to (1620087) was copied.
151111 21:35:27 completed OK!
acked chunk a3e9a9389924cb9e6229ad75e92618e7
a3e9a9389924cb9e6229ad75e92618e7 is done

Here is the command I run for restore( this is where I receive the error):

xbcloud get --storage=Swift --swift-container=$SWIFT_BACKUP_CONTAINER \
--swift-user=$SWIFT_BACKUP_USER --swift-auth-url=$SWIFT_BACKUP_AUTH_ADDRESS \
--swift-key=$SWIFT_BACKUP_KEY full_backup | xbstream -xv -C /tmp/

Has anyone ran across this issue?

Comments

  • noodlesnznoodlesnz Contributor Inactive User Role Beginner
    I have this problem as well, but the documentation around xbcloud is very limited at the moment and I can't get any response from Percona. I logged a bug here: https://bugs.launchpad.net/percona-xtrabackup/+bug/1510706
  • noodlesnznoodlesnz Contributor Inactive User Role Beginner
    I've just tested 2.3.3 and it doesn't look like this has been fixed. I have a job open with Percona to look at this, but I don't see it being done until the new year.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.