Not the answer you need?
Register and ask your own question!

pt-online-schema-change ERROR line 4320

cdavisoncdavison EntrantCurrent User Role Beginner
I am getting an error when I try to add a column to my mysql table. It says "you do not have the PROCESS privilege at /user/local/bin/pt-online-schema-change line 4320, <STDIN> line 1."

My command is below:
sudo pt-online-schema-change --alter "ADD COLUMN X INT" D=mydatabase,t='machine velocity',[email protected],u=my_username --execute --ask-pass

At first I thought maybe it was because my table title has a space in it, but I tried the same thing with another table with no spaces and had the same error.

When I run a dry run, there are no apparent errors. I only get this error when I change dry-run to execute.

Comments

  • scott.nemesscott.nemes MySQL Sage Current User Role Patron
    Hi cdavison;

    Looks like you need to grant the user you are running the tool with the "process" privilege. This privilege allows the user to run "show processlist", which the tool is likely doing for the safety checks.

    -Scott
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.