Not the answer you need?
Register and ask your own question!

Error enabling TokuDB - Percona Server not running with jemalloc enabled

user500user500 EntrantInactive User Role Beginner
Hi,

I'm having trouble enabling TokuDB with Percona Server 5.6.

I have installed:

- Ubuntu 14.04.3 LTS (GNU/Linux 3.13.0-63-generic x86_64)
- Percona Server 5.6.26-74.0-1.trusty
- Percona Server TokuDB 5.6.26-74.0-1.trusty
- libjemalloc1 3.6.0-2.trusty

In '/etc/mysql/my.cnf' under [mysqld_safe] I have added: 'malloc-lib = /usr/lib/x86_64-linux-gnu/libjemalloc.so.1'.

When I run 'sudo ps_tokudb_admin --enable -u root -p' I get:

Checking if Percona Server is running with jemalloc enabled...
ERROR: Percona Server is not running with jemalloc, please restart mysql service to enable it and then run this script...

The error remains after restarting the mysql service and the server.

Thank you,
Patrick
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.