Not the answer you need?
Register and ask your own question!

Failure adding node to new cluster

rollsrolls ContributorInactive User Role Beginner
Hi,

I't trying to set up a new cluster. the first master works fine but when i try to join a node into the cluster i have the following fail:

2015-09-17 09:31:48 28610 [Note] WSREP: Member 1.0 (xtradb3) requested state transfer from '*any*'. Selected 0.0 (xtradb1)(SYNCED) as donor.
2015-09-17 09:31:48 28610 [Note] WSREP: Shifting PRIMARY -> JOINER (TO: 15673804)
2015-09-17 09:31:48 28610 [Note] WSREP: Requesting state transfer: success, donor: 0
WSREP_SST: [INFO] Evaluating socat -u TCP-LISTEN:4444,reuseaddr stdio | tar xfi - --recursive-unlink -h; RC=( ${PIPESTATUS[@]} ) (20150917 09:31:48.201)
tar: ./backup-my.cnf: time stamp 2015-09-17 09:31:49 is 0.409071661 s in the future
2015-09-17 09:31:51 28610 [Note] WSREP: (c9fd7f2a, 'tcp://0.0.0.0:4567') turning message relay requesting off
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now
2015-09-17 09:37:17 28610 [Warning] WSREP: 0.0 (xtradb1): State transfer to 1.0 (xtradb3) failed: -22 (Invalid argument)
2015-09-17 09:37:17 28610 [ERROR] WSREP: gcs/src/gcs_group.cpp:int gcs_group_handle_join_msg(gcs_group_t*, const gcs_recv_msg_t*)():731: Will never receive state. Need to abort.
2015-09-17 09:37:17 28610 [Note] WSREP: gcomm: terminating thread
2015-09-17 09:37:17 28610 [Note] WSREP: gcomm: joining thread
WSREP_SST: [ERROR] Error while getting data from donor node: exit codes: 0 2 (20150917 09:37:17.676)
2015-09-17 09:37:17 28610 [Note] WSREP: gcomm: closing backend
WSREP_SST: [ERROR] Cleanup after exit with status:32 (20150917 09:37:17.682)
WSREP_SST: [INFO] Removing the sst_in_progress file (20150917 09:37:17.684)
2015-09-17 09:37:17 28610 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup --role 'joiner' --address '10.210.67.114' --auth 'sstuser:******' --datadir '/var/lib/mysql/' --defaults-file
'/etc/mysql/my.cnf' --defaults-group-suffix '' --parent '28610' '' : 32 (Broken pipe)
2015-09-17 09:37:17 28610 [ERROR] WSREP: Failed to read uuid:seqno from joiner script.
2015-09-17 09:37:17 28610 [ERROR] WSREP: SST failed: 32 (Broken pipe)
2015-09-17 09:37:17 28610 [ERROR] Aborting

2015-09-17 09:37:18 28610 [Note] WSREP: view(view_id(NON_PRIM,203f8ab6,31) memb {
c9fd7f2a,0
} joined {
} left {
} partitioned {
203f8ab6,0
})
2015-09-17 09:37:18 28610 [Note] WSREP: view((empty))
2015-09-17 09:37:18 28610 [Note] WSREP: gcomm: closed
2015-09-17 09:37:18 28610 [Note] WSREP: /usr/sbin/mysqld: Terminated.
Aborted


Anyone knows how to fix it?

Thanks!

Comments

  • mirfanmirfan Database Administrator Inactive User Role Beginner
    Please share error log, SST errors and innobackup log from donor node.
  • rollsrolls Contributor Inactive User Role Beginner
    >> log scanned up to (401257146534)
    >> log scanned up to (401257146534)
    >> log scanned up to (401257146534)
    >> log scanned up to (401257146534)
    >> log scanned up to (401257146534)
    innobackupex: got a fatal error with the following stacktrace: at /usr//bin/inno
    backupex line 2711.
    main::wait_for_ibbackup_file_create("/tmp/xtrabackup_suspended_2") calle
    d at /usr//bin/innobackupex line 2731
    main::wait_for_ibbackup_suspend("/tmp/xtrabackup_suspended_2") called at
    /usr//bin/innobackupex line 1984
    main::backup() called at /usr//bin/innobackupex line 1609
    innobackupex: Error: The xtrabackup child process has died at /usr//bin/innoback
    upex line 2711.
  • rollsrolls Contributor Inactive User Role Beginner
    i make another backup and i try to start again, it makes all the streams but when it takes 15 mins it says this

    >> log scanned up to (401601101914)
    >> log scanned up to (401601101914)
    xtrabackup: Error writing file 'UNOPENED' (Errcode: 32 - Broken pipe)
    archive_write_data() failed: (Empty error message) (errno = 0)
    [01] xtrabackup: Error: xtrabackup_copy_datafile() failed.
    [01] xtrabackup: Error: failed to copy datafile.
    innobackupex: got a fatal error with the following stacktrace: at /usr//bin/innobackupex line 2711.
    main::wait_for_ibbackup_file_create("/tmp/xtrabackup_suspended_2") called at /usr//bin/innobackupex line 2731
    main::wait_for_ibbackup_suspend("/tmp/xtrabackup_suspended_2") called at /usr//bin/innobackupex line 1984
    main::backup() called at /usr//bin/innobackupex line 1609
    innobackupex: Error: The xtrabackup child process has died at /usr//bin/innobackupex line 2711.
  • rollsrolls Contributor Inactive User Role Beginner
    The problem was a missmatch between nodes MySQL version (Donor 5.6 new 5.5)

    Thanks
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.